Apostrophe CMS Main Site Forum Home

Please help us evaluate a new syntax for Apostrophe modules


A new syntax for Apostrophe modules has been proposed. This is a big change, and we’d really like your input!

The goal here is to reduce the confusion developers experience with our current “beforeConstruct, construct, afterConstruct” setup and take advantage of patterns and naming conventions that are working well for other open source frameworks that have a need to configure modules, such as Vue.

Please comment on the github issue so we can keep our feedback in one place: